Skocz do zawartości


Close Open
Close Open

Internet Explorer 9, a css - wyświetlanie stron www.


  • Please log in to reply
2 replies to this topic

#1 GośćArtur_*

GośćArtur_*
  • Goście

Napisany 13 May 2011 - 19:43 PM

Witam,

Zauważyłem pewną przykrą przypadłość IE9. Po instalacji tej przeglądarki zmienia się położenie niektórych elementów na stronie internetowej.

Obserwacje:
1) Dotyczy Internet Explorer 9 i oczywiście Visty i 7
2) Przed instalacją IE9, czyli na IE8 (i Firefox 4!!) - nie ma żadnych problemów,
3) Po instalacji IE9 strona nieco zmienia kształt - rozjeżdża się tutaj
4) Dodatkowo Firefox 4 również wyświetla inaczej strony, czego nie było przed instalacją IE9

Wnioski:
1) IE9 zawiera jakiś dodatek do systemu operacyjnego, prawdopodobnie dotyczący czcionki, która zmienia rozmiar (może słynny textshadow) i przeglądarka rozwala to co jest na stronie. Dlatego problem dotyczy FF4 (ale dlaczego nie Opery i Chrome?)
2) na stronie są błędy, co zresztą jest bardzo możliwe, jednak przed instalacją IE9 wszystko jest ok nawet na FF4 - dlatego szukam przyczyny gdzie indziej.
3) Strona ma nietypowe czcionki i stąd problem.

Zapewne otrzymam słowa krytyki, że elementy na stronie pozycjonuje poprzez absolute, ale zanim zajmę się przerabianiem całej witryny może znajdzie się ktoś, kto pomógłby mi rozwiązać problem.

Dodatkowo zauważam, że zmiana rozmiaru czcionki poprzez mniemany dodatek systemowy instalowany wraz IE9 powodowałaby dokładnie to co się właśnie dzieje tj. zmiana rozmiarów menu o 3 px oraz inne rozmieszczenie wierszy w tekście opisowym tzn. inny rozmiar czcionki potrzebuje inną ilość miejsca na stronie co jest intuicyjne.

Czy ktoś z Was zna może podobny przypadek i mniej więcej wie o co chodzi i gdzie szukać problemu?
Czy ktoś zna nazwę pliku, który ingeruje w wygląd czcionek?
Czy może zna ktoś jakąś regułę wyjątku stosowaną w CSS w celu "przystosowania" do IE?

dotyczy www.laart.eu

Dziękuję i pozdrawiam
Artur

#2 GośćWażka_*

GośćWażka_*
  • Goście

Napisany 07 June 2011 - 13:08 PM

Mam dokładnie to samo, wszystko po instalacji IE9, nawet firefox 4 tez sie posypal :| Jeszcze nie znalazlem rozwiazania, ale szukam.

#3 GośćKolejny pechowiec_*

GośćKolejny pechowiec_*
  • Goście

Napisany 10 January 2012 - 17:02 PM

Też mam to samo. I nie ma mam pojęcia co jest grane.

Na programie wszystko ok a jak wrzucam na serwer i odpalam IE9 się delikatnie rozjeżdza.

Dopiero co poradziłem sobie z ustawieniem głównego diva wyśrodkowanego a tu kolejny problem...ehhh

Ktoś cos wymyślił?




0 Użytkowników czyta ten temat

0 użytkowników, 0 gości, 0 anonimowych użytkowników