Skocz do zawartości


Close Open
Close Open
Zdjęcie
- - - - -

zaokrąglenie godziny w excelu


  • Please log in to reply
5 replies to this topic

#1 shreker

shreker

    Adept

  • Forumowicze
  • Pip
  • 2 Postów:
  • Płeć:Kobieta

Napisany 22 December 2009 - 17:06 PM

Witam! Mam godzinę w formacie np. 12.35 , jak mogę zaokrąglić podaną godzinę do pełnej (w górę) tak aby otrzymać 13.

#2 navstevnik

navstevnik

    Początkujący

  • Forumowicze
  • PipPipPip
  • 73 Postów:
  • Płeć:Mężczyzna
  • Lokalizacja:Ostrava, Czechy

Napisany 22 December 2009 - 18:05 PM

w A1 godzina: 12:35
w B1: =ZAOKR.W.GÓRĘ(A1*1440;60)/1440 , formatuj komorke

#3 shreker

shreker

    Adept

  • Forumowicze
  • Pip
  • 2 Postów:
  • Płeć:Kobieta

Napisany 22 December 2009 - 18:20 PM

Niestety nie do końca jest to dobra formuła, 12.01 daje mi już 13.00 ! Po za tym chodziło mi o wynik w postaci np 12:35 = 13 , a nie 13.00 (zaokrąglenie do pełnej godziny bez minut)

#4 navstevnik

navstevnik

    Początkujący

  • Forumowicze
  • PipPipPip
  • 73 Postów:
  • Płeć:Mężczyzna
  • Lokalizacja:Ostrava, Czechy

Napisany 22 December 2009 - 19:10 PM

=JEŻELI(MOD(A1*1440;60)>=30;ZAOKR.W.GÓRĘ(A1*24;1);ZAOKR.W.DÓŁ(A1*24;1))

#5 birds22

birds22

    Entuzjasta

  • Forumowicze
  • PipPipPipPipPipPipPip
  • 1332 Postów:
  • Płeć:Mężczyzna
  • Lokalizacja:Zduńska Wola

Napisany 22 December 2009 - 20:17 PM

A czy tego samego nie uzyskamy tak:

=ZAOKR(A1*24;0)

??
Sławek

#6 S_L_A_W_E_K_

S_L_A_W_E_K_

    Adept

  • Forumowicze
  • Pip
  • 4 Postów:
  • Płeć:Kobieta

Napisany 05 January 2010 - 22:22 PM

a ja uzyskalem w ten sposób

komorki formatowałem do czasu i zastosowalem funkcje:

=ZAOKR.W.GÓRĘ(A1;"01:00")

A1 - to wpisana godz 13:35, formule zastosowalem np w komorce B2 i wyszla mi godz 14:00




0 Użytkowników czyta ten temat

0 użytkowników, 0 gości, 0 anonimowych użytkowników