Skocz do zawartości


Close Open
Close Open
Zdjęcie
- - - - -

Suma.Warunków w VBA


  • Please log in to reply
1 reply to this topic

#1 gumis_walcz

gumis_walcz

    Uczestnik

  • Forumowicze
  • PipPipPipPip
  • 104 Postów:

Napisany 08 sierpień 2017 - 08:36

Chciałem by uniknąć formuł w komórkach rozpisać funkcję suma.warunków jako makro.

=SUMA.WARUNKÓW($C$2:$C$8;$A$2:$A$8;$E2;$B$2:$B$8;F$1) 

Sumowana jest wartość z jednej kolumny. Warunki pobierane są jako zmienne wartości komórek arkusza.

Makro powinno się kończyć po określonej liczbie sprawdzonych wierszy.

 

Pytanie czy można Suma.Warunków przepisać na VBA ? :niewiem7vh:

Załączone pliki



#2 broda99

broda99

    Rozmowny

  • Forumowicze
  • PipPipPipPipPipPip
  • 551 Postów:
  • Płeć:Mężczyzna
  • Lokalizacja:W-wa

Napisany 09 sierpień 2017 - 05:26

Heh... Istota kodu mieści się w 6  linijkach:

 

d = Cells(Rows.Count, "C").End(xlUp).Row
s = 0
For i = 2 To d
    If Cells(i, 1) = Cells(2, 5) And Cells(i, 2) = Cells(1, 6) Then s = s + Cells(i, 3)
Next i
MsgBox "Suma wynosi " & s 

 

Tu masz plik: https://www.sendspace.com/file/8twcuf

Makro jest w Arkusz1 + inicjowanie w ThisWorkbook (Alt+F11) - jest trochę bardziej rozbudowane  ;).

Kod wykonuje pętlę do ostatniej wypełnionej komórki w kol. C (stara suma mu nie przeszkadza oby był przed nią pusty wiersz).






0 Użytkowników czyta ten temat

0 użytkowników, 0 gości, 0 anonimowych użytkowników